CVE-2017-12634GHSA-VF4Q-8MR7-5C5C
The camel-castor component in Apache Camel 2.x before 2.19.4 and 2.20.x before 2.20.1 is vulnerable to Java object de-serialisation vulnerab
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.19.4, 2.20.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The camel-castor component in Apache Camel 2.x before 2.19.4 and 2.20.x before 2.20.1 is vulnerable to Java object de-serialisation vulnerability. De-serializing untrusted data can lead to security flaws.
Timeline
- CVE published
- Record last updated
Affected versions
- Apache Software Foundation Apache Camel
2.19.0 to 2.19.3, 2.20.0
- org.apache.camel:camel-castorMaven
From 2.0.0 · fixed in 2.19.4
- org.apache.camel:camel-castorMaven
From 2.20.0 · fixed in 2.20.1