CVE-2017-12196GHSA-CP7V-VMV7-6X2Q
undertow before versions 1.4.18.SP1, 2.0.2.Final, 1.4.24.Final was found vulnerable when using Digest authentication, the server does not en
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.0.2.FInal, 1.4.24.Final
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
undertow before versions 1.4.18.SP1, 2.0.2.Final, 1.4.24.Final was found vulnerable when using Digest authentication, the server does not ensure that the value of URI in the Authorization header matches the URI in HTTP request line. This allows the attacker to cause a MITM attack and access the desired content on the server.
Timeline
- CVE published
- Record last updated
Affected versions
- unspecified undertow
undertow 1.4.18.SP1, undertow 2.0.2.Final, undertow 1.4.24.Final
- io.undertow:undertow-coreMaven
From 2.0.0.Alpha1 · fixed in 2.0.2.FInal
- io.undertow:undertow-coreMaven
fixed in 1.4.24.Final