CVE-2017-11480GO-2022-0643GHSA-9Q3G-M353-CP4P
Packetbeat versions prior to 5.6.4 are affected by a denial of service flaw in the PostgreSQL protocol handler.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 6.1.0+incompatible, 5.6.4, 6.0.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Packetbeat versions prior to 5.6.4 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.
Timeline
- CVE published
- Record last updated
Affected versions
- Elastic Packetbeat
before 5.6.4
- github.com/elastic/beatsGo
fixed in 6.1.0+incompatible
- github.com/elastic/beatsGo
fixed in 5.6.4
- github.com/elastic/beatsGo
From 6.0.0-alpha1 · fixed in 6.0.0