CVE-2017-11429GHSA-5P5W-J3G7-W4WV
Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.0, 2.0, 1.12.4, 2.0.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Clever saml2-js 2.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.
Timeline
- CVE published
- Record last updated
Affected versions
- Clever saml2-js
fixed in 1.0; fixed in 2.0
- saml2-jsnpm
fixed in 1.12.4
- saml2-jsnpm
From 2.0.0 · fixed in 2.0.2