Skip to main content
← All vulnerabilities
CVE-2017-1000207GHSA-VGVF-9JH3-FG75

A vulnerability in Swagger-Parser's version <= 1.0.30 and Swagger codegen version <= 2.2.2 yaml parsing functionality results in arbitrary c

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.0.31, 2.2.2
None on Exploit-DB, Metasploit or GitHub

Summary

A vulnerability in Swagger-Parser's version <= 1.0.30 and Swagger codegen version <= 2.2.2 yaml parsing functionality results in arbitrary code being executed when a maliciously crafted yaml Open-API specification is parsed. This in particular, affects the 'generate' and 'validate' command in swagger-codegen (<= 2.2.2) and can lead to arbitrary code being executed when these commands are used on a well-crafted yaml specification.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • io.swagger:swagger-parserMaven

    fixed in 1.0.31

  • io.swagger:swagger-codegenMaven

    fixed in 2.2.2

References 2

lgtm.com

GitHub · swagger-api/swagger-parser