CVE-2017-1000043GHSA-Q69P-5H74-W36F
Mapbox.js versions 1.x prior to 1.6.6 and 2.x prior to 2.2.4 are vulnerable to a cross-site-scripting attack in certain uncommon usage scena
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.6.6, 2.2.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Mapbox.js versions 1.x prior to 1.6.6 and 2.x prior to 2.2.4 are vulnerable to a cross-site-scripting attack in certain uncommon usage scenarios via TileJSON name and map share control
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- mapbox.jsnpm
fixed in 1.6.6
- mapbox.jsnpm
From 2.0.0 · fixed in 2.2.4
- mapbox-railsRubyGems
From 1.0.0 · fixed in 1.6.6
- mapbox-railsRubyGems
From 2.0.0 · fixed in 2.2.4