CVE-2017-0907GHSA-XPWP-RQ3X-X6V7
The Recurly Client .NET Library before 1.0.1, 1.1.10, 1.2.8, 1.3.2, 1.4.14, 1.5.3, 1.6.2, 1.7.1, 1.8.1 is vulnerable to a Server-Side Reques
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.0.1, 1.1.10, 1.2.8, 1.3.2, 1.4.14, and 4 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The Recurly Client .NET Library before 1.0.1, 1.1.10, 1.2.8, 1.3.2, 1.4.14, 1.5.3, 1.6.2, 1.7.1, 1.8.1 is vulnerable to a Server-Side Request Forgery vulnerability due to incorrect use of "Uri.EscapeUriString" that could result in compromise of API keys or other critical resources.
Timeline
- CVE published
- Record last updated
Affected versions
- Recurly recurly-api-client .NET library
Version range not reported
- recurly-api-clientNuGet
fixed in 1.0.1
- recurly-api-clientNuGet
From 1.1.0 · fixed in 1.1.10
- recurly-api-clientNuGet
From 1.2.0 · fixed in 1.2.8
- recurly-api-clientNuGet
From 1.3.0 · fixed in 1.3.2
- recurly-api-clientNuGet
From 1.4.0 · fixed in 1.4.14
- recurly-api-clientNuGet
From 1.5.0 · fixed in 1.5.3
- recurly-api-clientNuGet
From 1.6.0 · fixed in 1.6.2
- recurly-api-clientNuGet
From 1.7.0 · fixed in 1.7.1
- recurly-api-clientNuGet
From 1.8.0 · fixed in 1.8.1