CVE-2017-0906PYSEC-2017-68GHSA-38RV-5JQC-M2CV
The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery vu
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, and 2 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery vulnerability in the "Resource.get" method that could result in compromise of API keys or other critical resources.
Timeline
- CVE published
- Record last updated
Affected versions
- Recurly recurly python module
Version range not reported
- recurlyPyPI
From 2.0 · fixed in 2.0.5; From 2.1 · fixed in 2.1.16; From 2.2 · fixed in 2.2.22; From 2.3 · fixed in 2.3.1; From 2.4 · fixed in 2.4.5; From 2.5 · fixed in 2.5.1; From 2.6 · fixed in 2.6.2
- recurlyPyPI
From 2.6.0 · fixed in 2.6.2
- recurlyPyPI
From 2.5.0 · fixed in 2.5.1
- recurlyPyPI
From 2.4.0 · fixed in 2.4.5
- recurlyPyPI
From 2.3.0 · fixed in 2.3.1
- recurlyPyPI
From 2.2.0 · fixed in 2.2.22
- recurlyPyPI
From 2.1.0 · fixed in 2.1.16
- recurlyPyPI
fixed in 2.0.5