Skip to main content
← All vulnerabilities
CVE-2017-0905GHSA-X27V-X225-GQ8G

The Recurly Client Ruby Library before 2.0.13, 2.1.11, 2.2.5, 2.3.10, 2.4.11, 2.5.4, 2.6.3, 2.7.8, 2.8.2, 2.9.2, 2.10.4, 2.11.3 is vulnerabl

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.10, 2.2.5, 2.1.11, 2.0.13, 2.9.2, and 7 more
None on Exploit-DB, Metasploit or GitHub

Summary

The Recurly Client Ruby Library before 2.0.13, 2.1.11, 2.2.5, 2.3.10, 2.4.11, 2.5.4, 2.6.3, 2.7.8, 2.8.2, 2.9.2, 2.10.4, 2.11.3 is vulnerable to a Server-Side Request Forgery vulnerability in the "Resource#find" method that could result in compromise of API keys or other critical resources.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Recurly recurly ruby gem

    Version range not reported

  • recurlyRubyGems

    From 2.3.0 · fixed in 2.3.10

  • recurlyRubyGems

    From 2.2.0 · fixed in 2.2.5

  • recurlyRubyGems

    From 2.1.0 · fixed in 2.1.11

  • recurlyRubyGems

    From 2.0.0 · fixed in 2.0.13

  • recurlyRubyGems

    From 2.9.0 · fixed in 2.9.2

  • recurlyRubyGems

    From 2.8.0 · fixed in 2.8.2

  • recurlyRubyGems

    From 2.7.0 · fixed in 2.7.8

  • recurlyRubyGems

    From 2.6.0 · fixed in 2.6.3

  • recurlyRubyGems

    From 2.5.0 · fixed in 2.5.4

  • recurlyRubyGems

    From 2.4.0 · fixed in 2.4.11

  • recurlyRubyGems

    From 2.11.0 · fixed in 2.11.3

  • recurlyRubyGems

    From 2.10.0 · fixed in 2.10.4

References 3

dev.recurly.com

hackerone.com

GitHub · recurly/recurly-client-ruby