Skip to main content
← All vulnerabilities
CVE-2016-9856GHSA-J8MX-X32R-5RF4

An XSS issue was discovered in phpMyAdmin because of an improper fix for CVE-2016-2559 in PMASA-2016-10.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.6.5, 4.4.15.9, 4.0.10.18
None on Exploit-DB, Metasploit or GitHub

Summary

An XSS issue was discovered in phpMyAdmin because of an improper fix for CVE-2016-2559 in PMASA-2016-10. This issue is resolved by using a copy of a hash to avoid a race condition. All 4.6.x versions (prior to 4.6.5), 4.4.x versions (prior to 4.4.15.9), and 4.0.x versions (prior to 4.0.10.18) are affected.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • phpmyadmin/phpmyadminPackagist

    From 4.6 · fixed in 4.6.5

  • phpmyadmin/phpmyadminPackagist

    From 4.4 · fixed in 4.4.15.9

  • phpmyadmin/phpmyadminPackagist

    From 4.0 · fixed in 4.0.10.18

References 3

securityfocus.com

phpmyadmin.net

security.gentoo.org