Skip to main content
← All vulnerabilities
CVE-2016-9814GHSA-R8V4-7VWJ-983X

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x b

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.10.3, 1.8.1, 1.9.1, 2.3.3
None on Exploit-DB, Metasploit or GitHub

Summary

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • simplesamlphp/saml2Packagist

    From 1.10 · fixed in 1.10.3

  • simplesamlphp/saml2Packagist

    fixed in 1.8.1

  • simplesamlphp/saml2Packagist

    From 1.9.0 · fixed in 1.9.1

  • simplesamlphp/saml2Packagist

    From 2.0 · fixed in 2.3.3

References 3

securityfocus.com

simplesamlphp.org

lists.debian.org