CVE-2016-9587GHSA-M956-FRF4-M2WRPYSEC-2018-39
Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.1.4.0, 2.2.1.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 on Exploit-DB
Summary
Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed by Ansible and the ability to send facts back to the Ansible server could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.
Timeline
- Public exploit on Exploit-DB
EDB-41013
- CVE published
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- unspecified Ansible
ansible 2.1.4, ansible 2.2.1
- ansiblePyPI
fixed in 2.1.4.0
- ansiblePyPI
From 2.2.0.0 · fixed in 2.2.1.0
- ansiblePyPI
fixed in 2.1.4.0; From 2.2.0.0 · fixed in 2.2.1.0