Skip to main content
← All vulnerabilities
CVE-2016-8748GHSA-G2FM-X3CP-MQW9

In Apache NiFi before 1.0.1 and 1.1.x before 1.1.1, there is a cross-site scripting vulnerability in connection details dialog when accessed

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.0.1, 1.1.1
None on Exploit-DB, Metasploit or GitHub

Summary

In Apache NiFi before 1.0.1 and 1.1.x before 1.1.1, there is a cross-site scripting vulnerability in connection details dialog when accessed by an authorized user. The user supplied text was not being properly handled when added to the DOM.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Apache Software Foundation Apache NiFi

    1.0.0, 1.1.0

  • org.apache.nifi:nifiMaven

    fixed in 1.0.1

  • org.apache.nifi:nifiMaven

    From 1.1.0 · fixed in 1.1.1

References 2

securityfocus.com

nifi.apache.org