CVE-2016-8741GHSA-8VVH-CRQV-JM64
The Apache Qpid Broker for Java can be configured to use different so called AuthenticationProviders to handle user authentication.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 6.0.6, 6.1.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The Apache Qpid Broker for Java can be configured to use different so called AuthenticationProviders to handle user authentication. Among the choices are the SCRAM-SHA-1 and SCRAM-SHA-256 AuthenticationProvider types. It was discovered that these AuthenticationProviders in Apache Qpid Broker for Java 6.0.x before 6.0.6 and 6.1.x before 6.1.1 prematurely terminate the SCRAM SASL negotiation if the provided user name does not exist thus allowing remote attacker to determine the existence of user accounts. The Vulnerability does not apply to AuthenticationProviders other than SCRAM-SHA-1 and SCRAM-SHA-256.
Timeline
- CVE published
- Record last updated
Affected versions
- Apache Software Foundation Apache Qpid Broker-J
6.1.0
- org.apache.qpid:qpid-brokerMaven
From 6.0.0 · fixed in 6.0.6
- org.apache.qpid:qpid-brokerMaven
From 6.1.0 · fixed in 6.1.1