CVE-2016-8642GHSA-X32V-7QW8-CPQ8
In Moodle 2.x and 3.x, the question engine allows access to files that should not be available.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.1.3, 3.0.7, 2.9.9, 2.7.17
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
In Moodle 2.x and 3.x, the question engine allows access to files that should not be available.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a Moodle 2.x and 3.x
Version range not reported
- moodle/moodlePackagist
From 3.1.0 · fixed in 3.1.3
- moodle/moodlePackagist
From 3.0.0 · fixed in 3.0.7
- moodle/moodlePackagist
From 2.9.0 · fixed in 2.9.9
- moodle/moodlePackagist
From 2.8.0 · through 2.8.12
- moodle/moodlePackagist
From 2.7.0 · fixed in 2.7.17