CVE-2016-8640GHSA-HG4C-RGVM-964GPYSEC-2018-98
A SQL injection vulnerability in pycsw all versions before 2.0.2, 1.10.5 and 1.8.6 that leads to read and extract of any data from any table
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.0.2, 1.8.6, 1.10.5
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A SQL injection vulnerability in pycsw all versions before 2.0.2, 1.10.5 and 1.8.6 that leads to read and extract of any data from any table in the pycsw database that the database user has access to. Also on PostgreSQL (at least) it is possible to perform updates/inserts/deletes and database modifications to any table the database user has access to.
Timeline
- CVE published
- Record last updated
Affected versions
- https://github.com/geopython pycsw
Version range not reported
- pycswPyPI
From 2.0.0 · fixed in 2.0.2
- pycswPyPI
fixed in 1.8.6
- pycswPyPI
From 1.10.0 · fixed in 1.10.5
- pycswPyPI
fixed in 1.8.6; From 1.10.0 · fixed in 1.10.5; From 2.0.0 · fixed in 2.0.2