CVE-2016-6637GHSA-4M8C-H7FR-GQ5C
Multiple cross-site request forgery (CSRF) vulnerabilities in Pivotal Cloud Foundry (PCF) before 242; UAA 2.x before 2.7.4.7, 3.x before 3.3
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.7.4.7, 3.3.0.5, 3.4.4, 3.7.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Multiple cross-site request forgery (CSRF) vulnerabilities in Pivotal Cloud Foundry (PCF) before 242; UAA 2.x before 2.7.4.7, 3.x before 3.3.0.5, and 3.4.x before 3.4.4; UAA BOSH before 11.5 and 12.x before 12.5; Elastic Runtime before 1.6.40, 1.7.x before 1.7.21, and 1.8.x before 1.8.2; and Ops Manager 1.7.x before 1.7.13 and 1.8.x before 1.8.1 allow remote attackers to hijack the authentication of unspecified victims for requests that approve or deny a scope via a profile or authorize approval page.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 2.0.0 · fixed in 2.7.4.7
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 3.0.0 · fixed in 3.3.0.5
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 3.4.0 · fixed in 3.4.4
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 3.5.0 · fixed in 3.7.0