CVE-2016-6316GHSA-PC3M-V286-2JWJ
Cross-site scripting (XSS) vulnerability in Action View in Ruby on Rails 3.x before 3.2.22.3, 4.x before 4.2.7.1, and 5.x before 5.0.0.1 mig
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.2.22.3, 4.2.7.1, 5.0.0.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Cross-site scripting (XSS) vulnerability in Action View in Ruby on Rails 3.x before 3.2.22.3, 4.x before 4.2.7.1, and 5.x before 5.0.0.1 might allow remote attackers to inject arbitrary web script or HTML via text declared as "HTML safe" and used as attribute values in tag handlers.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- actionviewRubyGems
From 3.0.0 · fixed in 3.2.22.3
- actionviewRubyGems
From 4.0.0 · fixed in 4.2.7.1
- actionviewRubyGems
From 5.0.0 · fixed in 5.0.0.1