Skip to main content
← All vulnerabilities
CVE-2016-6186GHSA-C8C8-9472-W52HPYSEC-2016-2

Cross-site scripting (XSS) vulnerability in the dismissChangeRelatedObjectPopup function in contrib/admin/static/admin/js/admin/RelatedObjec

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.8.14, 1.9.8, 1.10rc1
1 on Exploit-DB

Summary

Cross-site scripting (XSS) vulnerability in the dismissChangeRelatedObjectPopup function in contrib/admin/static/admin/js/admin/RelatedObjectLookups.js in Django before 1.8.14, 1.9.x before 1.9.8, and 1.10.x before 1.10rc1 allows remote attackers to inject arbitrary web script or HTML via vectors involving unsafe usage of Element.innerHTML.

Timeline

  1. Public exploit on Exploit-DB

    EDB-40129

  2. CVE published
  3. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • djangoPyPI

    fixed in 1.8.14

  • djangoPyPI

    From 1.9 · fixed in 1.9.8

  • djangoPyPI

    From 1.10a1 · fixed in 1.10rc1

  • djangoPyPI

    fixed in 1.8.14; From 1.9 · fixed in 1.9.8; From 1.10a0 · fixed in 1.10rc1

References 18

securitytracker.com

seclists.org

rhn.redhat.com

debian.org

lists.fedoraproject.org

vulnerability-lab.com

securityfocus.com

packetstormsecurity.com

ubuntu.com

GitHub · django/django

djangoproject.com

Exploit-DB