Skip to main content
← All vulnerabilities
CVE-2016-5734GHSA-RV57-479X-X4QV

phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not properly choose delimiters to prevent use of the p

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.0.10.16, 4.4.15.7, 4.6.3
1 on Exploit-DB, 1 Metasploit module, 3 proofs of concept on GitHub

Summary

phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not properly choose delimiters to prevent use of the preg_replace e (aka eval) modifier, which might allow remote attackers to execute arbitrary PHP code via a crafted string, as demonstrated by the table search-and-replace implementation.

Timeline

  1. CVE published
  2. Public exploit on Exploit-DB

    EDB-40185

  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a n/a

    Version range not reported

  • phpmyadmin/phpmyadminPackagist

    From 4.0.10.0 · fixed in 4.0.10.16

  • phpmyadmin/phpmyadminPackagist

    From 4.4.15.0 · fixed in 4.4.15.7

  • phpmyadmin/phpmyadminPackagist

    From 4.6.0 · fixed in 4.6.3

References 11

Exploit-DB

GitHub · phpmyadmin/phpmyadmin

securityfocus.com

phpmyadmin.net

security.gentoo.org

GitHub · rapid7/metasploit-framework

GitHub · HKirito/phpmyadmin4.4_cve-2016-5734

GitHub · KosukeShimofuji/CVE-2016-5734

GitHub · miko550/CVE-2016-5734-docker